Main webpage chat screenshot

Minimum requirements to run IMsupporting live chat.

As our software is largely web based / cloud based, You don’t need any specific server setups and requirements.

Upgrades and Updates are handled by us free of charge and the platform is online 24×7.

With this said, Some users may experience issues if they run the system on older hardware and software. The reason for this is down to the nature of how our software works.

In today’s world, to offer a system like ours, we need to utilize some of the Internets greatest and newest features. This includes the newer HTML5 web standard.

Because of these newer requirements, the recommend you have a computer running the following:

Base requirements

Windows XP / 2000 / Vista / 7 / 8 / 8.1 / 10 running Google Chrome ( Recommended )
Windows XP / 2000 / Vista / 7 / 8 / 8.1 / 10 with Internet explorer 8 or above.
Windows XP / 2000 / Vista / 7 / 8 / 8.1 / 10 running Firefox
Linux running Google Chrome, Firefox or any other modern browser.
iOS / Apple OS running any modern browser ( Opera etc )

Additional requirements

Macromedia Flash
Javascript Enabled
Speakers for audio alerts

 

Generally our users have no problem running our software on older platforms however Internet Explorer 7 or earlier may not render our system correctly or possibly not work at all.

Unfortunately we can only recommend you upgrade or install another browser like Google Chrome. Not just to run our platform but its a good idea to upgrade from older browsers for your own security.

 

If you have any problems, Please contact our support team.